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PHUÏ LUÏC B1 

 GIAO DIEÄN ÑOÀ HOÏA  
I. KHÔÛI ÑOÄNG SAP 2000 

Töø Start choïn  > Programs > SAP2000 Nonlinear > SAP 2000 NonLinear. 

 
 Maøn hình chính cuûa cöûa soå chöông trình Sap 2000. 
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II. CAÙC CHÖÙC NAÊNG CUÛA CHÖÔNG TRÌNH SAP 2000 

1. Heä thoáng ñôn vò : Tröôùc khi  baïn muoán giaûi baøi toaùn baïn phaûi ñònh ñôn vò. Ñôn vò 
tính trong Sap 2000 seõ cung caáp cho baïn moät soá ñôn vò thöôøng duøng nhaát. Danh 
saùch cuûa caùc ñôn vò naèm treân thanh traïng thaùi beân döôùi phía phaûi cuûa maøn hình. 

 

Ñeå choïn ñôn vò tính baïn duøng chuoät nhaáp vaøo 
tam giaùc beân phaûi cuûa hoäp danh saùch, sau ñoù 
tröôït thanh tröôït ñöùng beân phaûi ñeå choïn ñôn vò 
maø baïn muoán. 

 Trong quaù trình khai baùo giaù trò nhaäp vaøo coù ñôn vò töông öùng vôùi ñôn vò hieän haønh ñang 
ñöôïc choïn, trong moät baøi toaùn cho baïn choïn nhieåu ñôn vò khaùc nhau ñeå khai baùo soá lieäu. Khi 
thöïc hieän tính toaùn taát caû caùc giaù trò ñeàu ñöôïc chuyeån ñoåi sang heä ñôn vò ñöôïc choïn ban ñaàu. 

2. Taïo moâ hình keát caáu :  

             Ñeå taïo moät moâ hình keát caáu baïn phaûi taïo 
heä thoáng löôùi, heä thoáng löôùi duøng ñeå xaùc ñònh toaï 
ñoä caùc ñieåm nuùt, veõ tröïc tieáp caùc phaàn töû maø 
khoâng caàn taïo caùc nuùt. Ñeå taïo heä thoáng löôùi baïn 
choïn leänh File > New Model hoaëc nhaán toå hôïp 
phím Ctrl+N ñeå xuaát hieän hoäp thoaïi Coordinate 
System Definition. 

 

 Hoäp thoaïi Coordinate System Definition xuaát hieän : 

  

Heä toïa ñoä vuoâng goùc Heä toïa ñoä truï 
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 Trong hoäp thoaïi Coordinate System Definition cho baïn hai heä truïc toaï ñoä ñeå taïo moâ 
hình keát caáu môùi ñoù laø heä toïa ñoä vuoâng goùc (Cartesian) vaø heä toaï ñoä truïc (Cylindrical). 

� Heä toïa ñoä Cartesian : 

System Name : teân heä toïa ñoä 

Number of Grid space : soá khoaûng 
caùch giöõa hai ñöôøng löôùi löôùi theo caùc 
truïc X, Y, Z. 

Grid spacing : khoaûng caùch giöõa caùc 
löôùi theo caùc truïc X, Y, Z.  

� Heä toïa ñoä truï Cylindrical : 

System Name : teân heä toïa  ñoä 

Number of Grid space :  soá khoaûng caùch löôùi theo caùc phöông R, ϕ, Z  

Grid spacing : khoaûng caùch giöõa caùc löôùi theo caùc truïc R, ϕ, Z. 

Ví duï : Baïn muoán veõ moâ hình  cuûa thanh daøn coù chieàu daøi laø 4m vaø chieàu cao laø 3 m, baïn thöïc 
hieän nhö sau : 

� Khôûi ñoäng Sap 2000 sau ñoù baïn choïn ñôn vò tính laø T/m. 

� Tieáp theo baïn taïo löôùi baèng caùch vaøo trình ñôn File > New Model 

Hoäp thoaïi Coordinate System Definition xuaát hieän. 

 
 Trong hoäp thoaïi Coordinate System Definition baïn duøng chuoät nhaáp choïn vaøo 
Catesian vaø nhaäp vaøo giaù trò nhö sau: 
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Number of Grid space : X Diretion : 2, Y Diretion : 0, Z Diretion : 3  

Grid spacing : X Diretion : 4, Y Diretion : 1, Z Diretion : 2 vaø nhaáp choïn Ok keát quaû nhö 
hình sau : 

 
 Ñeå deã nhìn thaáy baïn vaøo trình ñôn View > Set 2D view. 

 
 Trong hoäp thoaïi Set 2D View baïn nhaáp choïn vaøo X_Yplane vaø nhaáp choïn OK. 
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Moâ hình ñaõ xuaát hieän vôùi chieàu daøi laø 4m theo phöông truïc X vaø phöông truïc Z laø 3 m. 

3. MOÂ HÌNH KEÁT CAÁU MAÃU  

Trong chöông trình Sap 2000 ñaõ cho baïn moät soá moâ hình keát caáu maãu trong thö vieän. Ñeå 
xem moâ hình maãu baïn vaøo trình ñôn File > New Model from Template. 

 
 Hoäp thoaïi Model Templates xuaát hieän. 

 
Trong hoäp thoaïi Model Templates cho baïn 9 loaïi maãu keát caáu ñeå xem chöùc naêng cuûa 
moãi loaïi keát caáu nhö theá naøo baïn haõy khaùm phaù töøng maãu Model Templates. 
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� HEÄ DAÀM LIEÂN TUÏC 

Ví duï : Cho moät daàm lieân tuïc, vôùi chieàu daøi cuûa daàm laø 8m goàm 2 nhòp, chieàu daøi cuûa 
moãi nhòp laø 4m. 

          Ñeå giaûi baøi toaùn daàm lieân tuïc baïn duøng chuoät nhaáp 
choïn vaøo bieåu töông daàm lieân tuïc trong hoäp Model 
Templates. 

 
 Hoäp thoaïi Beam xuaát hieän 

 
 Trong hoäp thoaïi Beam baïn khai baùo nhö sau : 

9 Taïi muïc Numer of Spans (Soá nhòp) baïn nhaäp vaøo giaù trò laø 2 

9 Taïi muïc Span Length (chieàu daøi cuûa moãi nhòp) nhaäp giaù trò laø 4 vaø nhaáp choïn OK. 

9 Restraints caùc lieân keát maëc ñònh 

9 Gridlines taïo saün heä ñöôøng löôùi toaï ñoä. 

Chuù yù : Sap 2000 ñaõ maëc ñònh caùc lieân keát vaø nhöõng ñöôøng löôùi, baïn coù theå boû ñi baèng 
caùch duøng chuoät kích choïn vaøo hai oâ naøy. 

 
 Hình khi thöïc hieän xong moät daàm goàm 2 nhòp 
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� HEÄ KHUNG PHAÚNG TRONG MAËT PHAÚNG X-Z 

Ví duï : Taïo moät khung phaúng goàm 2 taàng, 3 nhòp, chieàu cao moãi taàng laø 5 m, chieàu roäng 
cuûa moãi nhòp laø 3m . 

Ñeå taïo moâ hình khung phaúng baïn duøng chuoät nhaáp choïn vaøo bieåu töôïng thöù hai cuûa hoäp 
thoaïi Model Templates nhö hình con troû chæ beân döôùi. 

 
 Hoäp thoaïi Portal Frame xuaát hieän 

 
 Trong hoäp thoaïi Portal Frame baïn duøng chuoät nhaáp choïn vaøo Gridlines ñeå daáu ñi ñöôøng 
löôùi sau ñoù baïn khai baùo theo trình töï sau: 

• Number of Stories (toång soá taàng) baïn nhaäp vaøo giaù trò laø 2 

• Number of Bays (toång soá nhòp) nhaäp giaù trò laø 3 

• Story Height (chieàu cao moät taàng) : 5 

• Bay Width (beà roäng cuûa moät nhòp) : 3 

• Nhaáp choïn vaøo Ok ñeå ñoùng hoäp thoaïi. 

 

THIEÁT KEÁ VÔÙI SÖÏ TRÔÏ GIUÙP CUÛA MAÙY TÍNH                                                                         BIEÂN SOAÏN : TUÛ SAÙCH STK 232 



TÍNH TOAÙN THIEÁT KEÁ KEÁT CAÁU BAÈNG CHÖÔNG TRÌNH SAP 2000 – TÖÏ HOÏC SAP 2000 BAÈNG HÌNH AÛNH 
 

 

Hình khi thöïc hieän xong 

� VAÙCH CÖÙNG  

Nhaáp choïn vaøo bieåu töôïng vaùch cöùng nhö hình muõi teân beân döôùi ñeå xuaát hieän hoäp 
thoaïi Shear Wall. 

 

Trong hoäp thoaïi Shear Wall : 

• Number ofspaces along X : Soá oâ löôùi theo truïc X. 

• Number ofspaces along Y : Soá oâ löôùi theo truïc Y. 

• Space Width along X,Y : Chieåu roäng moät oâ löôùi theo truïc X, Z töông öùng. 

� HEÄ KHUNG PHAÚNG COÙ THANH GIAÈNG  

     Heä khung phaúng coù thanh giaèng cuõng töông töï nhö heä khung phaúng. 

 Trong hoäp Model Templates nhaáp choïn vaøo bieåu töôïng khung phaúng coù thanh giaèng ñeå 
xuaát hieän hoäp thoaïi Eccentric Frame. 
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• Number of Stories (toång soá taàng) baïn nhaäp vaøo giaù trò laø 2 

• Number of Bays (toång soá nhòp) nhaäp giaù trò laø 3 

• Story Height (chieàu cao moät taàng) : 3 

• Bay Width (beà roäng cuûa moät nhòp) : 6 

• Gap width (ñoä roäng cuûa khe hôû) :1 

� MAËT TRUÏ 

Nhaáp choïn vaøo bieåu töôïng maët truï ñeå xuaát hieän hoäp thoaïi Cylinder. 

 

 Trong hoäp thoaïi Cylinder : 

• Number of Cirumferential Spaces : Soá khoaûng caùch löôùi theo chu vi 

• Number of Height Spaces : Soá khoaûng caùch löôùi theo chieàu cao cuûa maët truï 

• Cylinder Height : Chieàu cao cuûa maët truï 

• Radius : Baùn kính cuûa maët truï 
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� HEÄ KHUNG KHOÂNG GIAN  COÙ HEÄ THOÁNG DAÀM LIEÂN KEÁT BEÂN TRONG 

Nhaáp choïn vaøo bieåu töôïng khung khoâng gian ñeå xuaát hieän hoäp thoaïi Space Frame. 

 
• Number of Stories : Toång soá taàng cuûa heä khung 

• Number of Bays along X, Y: Toång soá nhòp theo phöông X,Y 

• Story Height : Chieàu cao moät taàng theo phöông Z 

• Bay Width along X, Y  : Beà roäng cuûa moät nhòp theo phöông X,Y 

� HEÄ KHUNG KHOÂNG GIAN KHOÂNG COÙ HEÄ THOÁNG DAÀM ÑÔÕ BEÂN TRONG 

Trong hoäp thoaïi Model Templates nhaáp choïn vaøo bieåu töôïng khung khoâng gian ñeå xuaát 
hieän hoäp thoaïi Perimeter Frame. 

 
Hoäp thoaïi Perimeter Frame xuaát hieän 
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Trong hoäp thoaïi Perimeter Frame : 

• Number of Stories : Toång soá taàng cuûa heä khung 

• Number of Bays along X, Y: Toång soá nhòp theo phöông X,Y 

• Story Height : Chieàu cao moät taàng theo phöông Z 

• Bay Width along X, Y  : Beà roäng cuûa moät nhòp theo phöông X,Y 

� HEÄ MAËT TRUÏ VOÛ MOÛNG 

Trong hoäp thoaïi Model Templates nhaáp choïn vaøo bieåu töôïng maët truï ñeå xuaát hieän hoäp thoaïi 
Barrel. 

 
 Trong hoäp thoaïi Barrel : 

• Number of Circumferential Spaces : Soá khoaûng chia cung theo chu vi 

• Number of Span Spaces : Soá khoaûng chia böôùc löôùi theo ñöôøng sinh cuûa maët truï 

• Span : Chieàu cao cuûa moät böôùc löôùi  

• Radius : Baùn kính maët truï 

• Roll Down Angle : Goùc kheùp cuûa maët truï 

Chuù yù : Maëc ñònh, maët truï luoân coù baùn kính qua ñænh cuûa maët truï höôùng theo ñöôøng cuûa 
truïc Z, ñöôøng sinh cuûa noù song song vôùi truïc X. 

� CHOÛM CAÀU VOÛ MOÛNG 

Trong hoäp thoaïi Model Templates nhaáp choïn vaøo bieåu töôïng choûm caàu ñeå xuaát hieän hoäp 
thoaïi Dome. 
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 Trong hoäp thoaïi Dome : 

• Number of Circumferential Spaces : Soá khoaûng chia treân ñöôøng vó tuyeán  

• Number of Segments : Soá ñoaïn chia theo kinh tuyeán 

• Radius : Baùn kính choûm caàu 

• Roll down angle  : Goùc choûm caàu (goùc hôïp bôûi taâm vaø hai ñieåm cuoái treân ñöôøng 
kính cuûa ñöôøng vó tuyeán thaáp nhaát) 

� CAÀU DAØN PHAÚNG 

Trong hoäp thoaïi Model Templates nhaáp choïn vaøo bieåu töôïng caàu daøn ñeå xuaát hieän hoäp 
thoaïi Vertical Truss. 

 

  

 Trong hoäp thoaïi Vertical Truss: 

• Numbet of Bays : Soá nhòp cuûa daøn 

• Height of Truss : Chieàu cao cuûa daøn 

• Truss Bay Length : Chieàu daøi cuûa moãi nhòp 

Chuù yù : Maëc ñònh heä daøn phaúng luoân naèm trong maët phaúng OXZ. 
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� HEÄ THANH DAØN KHOÂNG GIAN 

Trong hoäp thoaïi Model Templates nhaáp choïn vaøo bieåu töôïng heä thanh daøn ñeå xuaát hieän 
hoäp thoaïi Space Truss. 

 

Trong hoäp thoaïi Space Truss : 

• Number of Stories : Toång soá taàng cuûa heä khung 

• Story Height : Chieàu cao moät taàng theo phöông Z 

• Top width along X, Y : Beà roäng cuûa ñænh daøn theo phöông truïc X, Y 

• Bottom width along X, Y: Beà roäng cuûa ñaùy daøn theo phöông truïc X, Y 

� KEÁT CAÁU SAØN COÙ COÄT ÑÔÕ 

Trong hoäp thoaïi Model Templates nhaáp choïn vaøo bieåu töôïng saøn ñeå xuaát hieän hoäp thoaïi 
Floor. 

 

 Trong hoäp thoaïi Floor : 

• Number of Spaces along X, Y : Soá khoaûng chia theo phöông X, Y 

• Space Width along X, Y : Ñoä daøi cuûa moãi khoaûng chia theo phöông X, Y 

• Middle Strip width along X, Y : Ñoä roãng cuûa daûi qua caùc goái ñôõ theo phöông X, 
Y. 
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� HEÄ KEÁT CAÁU CAÀU ÑÔN GIAÛN 

Trong hoäp thoaïi Model Templates nhaáp choïn vaøo bieåu töôïng caàu ñeå xuaát hieän hoäp thoaïi 
Bridge. 

 
 Trong hoäp thoaïi Bridge 

• Number of Spans : Soá nhòp cuûa heä 

• Number of Griders : Soá daàm ngang 

• Number of Columns : Toång soá coät 

• Span Length : Chieàu daøi nhòp 

• Column Spacing : Khoaûng caùch giöõa caùc coät, coät vuoâng goùc vôùi daàm ngang 

• Column Height : Chieàu cao cuûa coät  

• Skew Angle : Goùc xieân giöõa maët phaúng caàu vôùi maët phaúng naèm ngang. 

4. MÔÛ VAØ LÖU FILE  

             Ñeå môû moät file döõ lieäu trong chöông 
trình Sap 2000 baïn vaøo trình ñôn File > Open 
hay nhaán toå hôïp phím Ctrl + O. 

 
Hoäp thoaïi Open Model File xuaát hieän : 

 

THIEÁT KEÁ VÔÙI SÖÏ TRÔÏ GIUÙP CUÛA MAÙY TÍNH                                                                         BIEÂN SOAÏN : TUÛ SAÙCH STK 239 



TÍNH TOAÙN THIEÁT KEÁ KEÁT CAÁU BAÈNG CHÖÔNG TRÌNH SAP 2000 – TÖÏ HOÏC SAP 2000 BAÈNG HÌNH AÛNH 
 
 Trong hoäp thoaïi Open Model File baïn choïn ñöôøng daãn ñeå môû file baèng caùch trong muïc 
Look in baïn duøng chuoät nhaáp choïn vaøo tam giaùc beân phaûi ñeå choïn thö muïc maø baïn ñaõ löu. 

Ví duï : Baïn môû file Exconc trong Sap 2000 baèng caùch : Trong muïc Look in nhaáp chuoät 
vaøo tam giaùc beân phaûi ñeå choïn choïn thö muïc Sap 2000n, sau ñoù baïn nhaáp ñuùp vaøo Example ñeå 
xuaát hieän Exconc , nhaáp chuoät vaøo Exconc vaø nhaáp choïn Open ñeå môû File.  

 
Khi nhaáp choïn vaøo Open moät File ñaõ ñöôïc môû ra nhö hình sau : 

 
� LÖU FILE 

Khi file Exconc ñaõ ñöôïc môû ôû treân, baây giôø baïn muoán ñaëc moät teân khaùc (khung phang) 
cho file  naøy baèng caùch vaøo trình ñôn File > Save As hay nhaán F2 treân baøn phím ñeå xuaát 
hieän hoäp thoaïi Save Model File As. 
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 Hoäp thoaïi Save Model File As xuaát hieän : 

 

 Trong hoäp thoaïi Save Model File As taïi muïc Save in baïn duøng chuoät nhaáp choïn vaøo tam 
giaùc beân phaûi ñeå choïn thö muïc maø baïn muoán löu file, Ví duï ôû ñaây toâi muoán löu file trong thö 
muïc Example. Trong muïc File name nhaäp vaøo teân “khung phang”, taïi muïc Save as type nhaáp 
choïn vaøo tam giaùc beân phaûi ñeå choïn ñònh daïng cho file coù phaàn môû roäng laø *.SDB, vaø nhaáp 
choïn vaøo Save ñeå löu file. Luùc baáy giôø File coù teân Exconc ñaõ ñöôïc löu vaø ñoåi teân thaønh khung 
phang. 

 Trong quaù trình ñang tieán haønh khai baùo nhöõng thoâng soá cho baøi toaùn, muoán löu file baïn 
nhaáp vaøo bieåu töôïng  , hay duøng toå hôïp phím Ctrl + S. 
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